Cricket Player Manager
Page 4 of 6 FirstFirst ... 23456 LastLast
Results 46 to 60 of 78
Like Tree10Likes

Thread: First unread post issue

  1. #46
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    Something else to try...

    From VB 4.2.1 issue with IE10 - not ckeditor related - vBulletin Community Forum:



    AdminCP >> Maintenance >> General Update Tools >> Rebuild Thread Information

    While you're there, you might also do Rebuild Forum Information
    Done.

    Did you see my email about the vbseo settings btw?

  2. #47
    Cricket Spectator
    Join Date
    Jul 2013
    Location
    Ottawa, Canada
    Posts
    23
    Quote Originally Posted by James View Post
    Done.

    Did you see my email about the vbseo settings btw?
    Yes but haven't had a chance to look at it further yet.

    *** Can you ask select members to see whether rebuilding forums and threads made any difference?

  3. #48
    Cricket Spectator
    Join Date
    Jul 2013
    Location
    Ottawa, Canada
    Posts
    23
    Try this:

    Login Required - vBulletin JIRA

    or some reason go to first unread post no working on IE9 and Opera 11.50
    when use Standard URLs
    Enforce Canonical URL is set to Standart or Strict.
    when Enforce Canonical URL option set to off - work as designed. Example (not working):
    when click on 'go to first unread post'
    URL look like this
    http://www.forum.com/showthread.php?t=48178&p=1599607
    missing anchor #1599607
    working :
    when Enforce Canonical URL option set to off URL look like this
    http://www.forum.com/showthread.php?t=48178&p=1599607#post1599607

    -------------------------

    Confirmed. When using Standard URLs and Enforce Canonical URLs is enabled, post anchors are being stripped from links (so for example also from the go to last post link).


    It is related to 6101.
    Basically when the page is being re-directed, its losing the anchor.
    FF seems to be quite clever in that it remembers the anchor, and adds it back again after the redirect. IE and others are not so clever, and so they fail.


    -------------------------------

    Doesn't entirely explain why it works on some forums and not on others but give it a try.

  4. #49
    Cricket Spectator
    Join Date
    Jul 2013
    Location
    Ottawa, Canada
    Posts
    23
    One more diagnostic to run:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Does this highlight any core vBulletin files that are not obviously related to an add-on product or plugin?


  5. #50
    Cricket Spectator
    Join Date
    Jul 2013
    Location
    Ottawa, Canada
    Posts
    23
    And:

    Create a new style and choose no parent style. This will force it to use the default templates.
    Set it so that it's available for members to use (temporarily) so I can access it please.

  6. #51
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    Try this:

    Login Required - vBulletin JIRA

    or some reason go to first unread post no working on IE9 and Opera 11.50
    when use Standard URLs
    Enforce Canonical URL is set to Standart or Strict.
    when Enforce Canonical URL option set to off - work as designed. Example (not working):
    when click on 'go to first unread post'
    URL look like this
    http://www.forum.com/showthread.php?t=48178&p=1599607
    missing anchor #1599607
    working :
    when Enforce Canonical URL option set to off URL look like this
    http://www.forum.com/showthread.php?t=48178&p=1599607#post1599607

    -------------------------

    Confirmed. When using Standard URLs and Enforce Canonical URLs is enabled, post anchors are being stripped from links (so for example also from the go to last post link).


    It is related to 6101.
    Basically when the page is being re-directed, its losing the anchor.
    FF seems to be quite clever in that it remembers the anchor, and adds it back again after the redirect. IE and others are not so clever, and so they fail.


    -------------------------------

    Doesn't entirely explain why it works on some forums and not on others but give it a try.
    What do I need to change here? I don't really understand it.

  7. #52
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    *** Can you ask select members to see whether rebuilding forums and threads made any difference?
    Will do.

  8. #53
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    One more diagnostic to run:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Does this highlight any core vBulletin files that are not obviously related to an add-on product or plugin?
    Done, and sent to you.

  9. #54
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    And:

    Create a new style and choose no parent style. This will force it to use the default templates.
    Set it so that it's available for members to use (temporarily) so I can access it please.
    Already done actually, and available as "Default vbulletin"

  10. #55
    Cricket Spectator
    Join Date
    Jul 2013
    Location
    Ottawa, Canada
    Posts
    23
    Quote Originally Posted by James View Post
    What do I need to change here? I don't really understand it.
    AdminCP >> Settings >> Options >> Friendly URLs

    URL Type = Standard

    Enforce Canonical URL = Off

  11. #56
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    AdminCP >> Settings >> Options >> Friendly URLs

    URL Type = Standard

    Enforce Canonical URL = Off
    Thanks for clarifying

    URL Type was Standard.

    Enforce Canonical URL was set to Yes, is now set to No.

  12. #57
    Cricket Spectator
    Join Date
    Jul 2013
    Location
    Ottawa, Canada
    Posts
    23
    Quote Originally Posted by James View Post
    Thanks for clarifying

    URL Type was Standard.

    Enforce Canonical URL was set to Yes, is now set to No.
    Holy cow! This seems to have worked, James. I have just tried it in Firefox, IE10, and Safari and it is now working as it should for me.

    Can you ask your members to try and ask them to report back?

  13. #58
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by djbaxter View Post
    Holy cow! This seems to have worked, James. I have just tried it in Firefox, IE10, and Safari and it is now working as it should for me.

    Can you ask your members to try and ask them to report back?
    Yes, that seems to have done the trick! Magic! One of the members has tested and told me all appears to be good now.

    Let's give it a couple of days and see if anything comes up though
    djbaxter likes this.

  14. #59
    Global Moderator Fusion's Avatar
    Join Date
    Nov 2005
    Location
    United States
    Posts
    11,556
    It seems to be working for me as well James. I'll post here if I notice another issue. Thanks!
    djbaxter likes this.

  15. #60
    Cricket Web Owner James's Avatar
    Join Date
    Oct 2001
    Location
    Sydney, Australia
    Posts
    24,032
    Quote Originally Posted by Fusion View Post
    It seems to be working for me as well James. I'll post here if I notice another issue. Thanks!
    Good to hear Fusion, and the fix is all down to djbaxter Where vbulletin and vbseo support both couldn't be bothered helping, he very kindly saw this through to a solution for us.
    Fusion likes this.

Page 4 of 6 FirstFirst ... 23456 LastLast


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i've got a friend with an issue
    By nibbs in forum Off Topic
    Replies: 33
    Last Post: 10-11-2007, 05:43 PM
  2. a delicate issue
    By nibbs in forum Off Topic
    Replies: 30
    Last Post: 28-06-2005, 05:15 AM
  3. View first unread post
    By Bazza in forum Site Discussion
    Replies: 11
    Last Post: 16-01-2003, 03:51 PM
  4. 1st issue newsletter
    By bugssy in forum World Club Cricket
    Replies: 10
    Last Post: 15-10-2002, 10:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •